Power BI Spain Users Group

Please login or click SIGN UP FOR FREE to create your PowerBIUG account to join this user group.
 View Only
  • 1.  Duda en el visual tabla

    Silver Contributor
    Posted Aug 29, 2020 08:18 AM
    Hola a todos
    Estoy probando de mostrar en un visual tipo tabla todas las lineas de una tabla llamada Modelo y le añado una medida que es la suma de una columna de la tabla Datos. Adjunto teneis el PBI y el Excel con las dos tablas que uso.
    En la tabla Modelo hay lineas que solo son descripciones y que no deben mostrar ningun valor y hay otras lineas que deben mostrar, ademas de los datos de la tabla modelo, una de las dos medidas. Una medida me devuelve siempre un valor numerico, la otra medida, si no hay valor a mostrar, devuelve un blanco.e

    En el PBI vereis que si utilizo la medida que siempre devuelve un valor se muestran todas las lineas de la tabla modelo, si en cambio si muestro la medida que puede devolver un blanco, no se muestran todas las lineas de la tabla Modelo


    ¿Alguna idea de lo que no estoy haciendo bien?


    ------------------------------
    Josep M Puigdollers
    ------------------------------

    Attachment(s)

    pbix
    Prueba.pbix   46 KB 1 version
    xlsx
    Prueba.xlsx   11 KB 1 version


  • 2.  RE: Duda en el visual tabla

    Bronze Contributor
    Posted Aug 29, 2020 10:20 AM

    Hola Josep M.

     

    Como me imagino que sólo querrás el título en aquellos registros en los que no exista [CodigoID] puedes poner la medida de la siguiente forma:

    Suma Importe Blank =

        IF (

            ISBLANK(SELECTEDVALUE(Modelo[CodigoID]));

            "";

            SUM(Datos[Importe])

        )

     

     

    Espero que te sirva.

     

    Vicente

     

     






  • 3.  RE: Duda en el visual tabla

    Silver Contributor
    Posted Aug 29, 2020 11:15 AM
    Gracias Vicente por la aportacion pero lo que me preocupa en realidad es el distinto comportamiento de la tabla con las dos medidas. Porque con una se filtran las lineas y con la otra no.





    ------------------------------
    Josep M Puigdollers
    ------------------------------



  • 4.  RE: Duda en el visual tabla

    Bronze Contributor
    Posted Aug 29, 2020 12:10 PM

    Hola Josep M.

     

    Creo que es un tema de la visualización tipo 'tabla'. En ese tipo de visualización no se devuelven los registros que contienen BLANK. Debe ser algo interno.

     

    Si pones la misma medida en una matriz con el campo 'ID' en la fila y el resto en valores (aunque te renombrará 'CodigoID' y 'Descripción' por no ser medidas) sí que aparecen los registros que contienen BLANK.

     

    Espero que te sirva,

     

    Vicente