Club Power BI

Please login or click SIGN UP FOR FREE to create your PowerBIUG account to join this user group.
Expand all | Collapse all

filtrer avec un SELECTEDVALUE ne fonctionne pas

  • 1.  filtrer avec un SELECTEDVALUE ne fonctionne pas

    Posted 27 days ago
    Bonjour à tous,
    dans un rapport Power BI, je souhaiterais compter le nombre d'éléments d'une table, suivant l'année sélectionnée par un utilisateur dans un segment
    Pour récupérer la valeur du segment, j'utilise cette commande DAX qui me retourne bien l'année sélectionnée :
    AnneeChoisie = VALUE(SELECTEDVALUE('Années'[Année],2018))

    Mais si je souhaite compter le nombre de projets pour l'année sélectionne, cela me renvoie toujours 3 (l'année 2018, qui est la valeur par défaut de SELECTEDVALUE)
    Voici ma mesure:
    Nb Projets =
    CALCULATE(
    COUNT(Projets[Projet]),
    FILTER(Projets,Projets[Année Début]=[AnneeChoisie]))

    Avez-vous une idée de ce comportement ?


    ------------------------------
    LAURENT SANCHEZ
    Developer
    laurent@sanchezconsultant.com
    LE HAVRE
    662527022
    ------------------------------


  • 2.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Top Contributor
    Posted 26 days ago
    Bonjour,

    Je pense qu'il manque juste un All après Filter.

    Bon courage,

    ------------------------------
    Jonathan CHANAL
    Chef de Projet Digital / Data Analyst
    MCSA Power BI & Excel
    ------------------------------



  • 3.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Posted 26 days ago
      |   view attached
    Bonjour  Jonathan,
    tout d'abord merci d'avoir répondu à ce post, mais malgré l'utilisation de ALL, je n'ai pas de modifications :
    Nb Projets =
    CALCULATE(COUNT(Projets[Projet]),FILTER(ALL(Projets),Projets[Année Début]=[AnneeChoisie]))

    Je me permets de vous joindre le PBIX où j'ai l'erreur...


    ------------------------------
    LAURENT SANCHEZ
    Developer
    laurent@sanchezconsultant.com
    LE HAVRE
    662527022
    ------------------------------

    Attachment(s)



  • 4.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Top Contributor
    Posted 25 days ago
      |   view attached
    Bonjour Laurent,

    J'ai rajouté une table des dates (je pense que c'est vraiment indispensable quel que soit le projet).

    Ensuite ma nouvelle mesure :
    Nb Projets = CALCULATE(COUNTROWS(VALUES(Projets[Projet])))

    Bon courage pour la suite de votre projet


    ------------------------------
    Jonathan CHANAL
    Chef de Projet Digital / Data Analyst
    MCSA Power BI & Excel
    ------------------------------

    Attachment(s)



  • 5.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Posted 24 days ago
    Bonjour Jonathan,
    merci pour votre retour, mais je connais le use case de la table des dates,  mais je voulais tester ici un FILTER avec un SELECTEDVALUE, et voir pourquoi il ne parvient pas à filtrer quand on lui indique un SELECTEDVALUE en paramètre :

    Nb Projets =
    CALCULATE(
    COUNTROWS(Projets),
    FILTER(ALL(Projets),
    Projets[Année Début]=VALUE(SELECTEDVALUE('Années'[Année],2018))

    ?



    ------------------------------
    LAURENT SANCHEZ
    Developer
    laurent@sanchezconsultant.com
    LE HAVRE
    662527022
    ------------------------------



  • 6.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Top Contributor
    Posted 24 days ago
      |   view attached
    Bonjour Laurent,

    J'ai repris le modèle, vous aviez désactivé les interactions entre les visuels. De plus, il manque la relation entre les deux tables. Une fois ces deux problèmes rectifiés, les mesures fonctionnent normalement

    DISTINCTCOUNT(Projets[Projet])

    Bon courage,


    ------------------------------
    Jonathan CHANAL
    Chef de Projet Digital / Data Analyst
    MCSA Power BI & Excel
    ------------------------------

    Attachment(s)



  • 7.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Posted 24 days ago
    Bonjour Jonathan,
    merci pour votre retour, effectivement j'avais modifié les intéractions !

    Cela fonctionne bien désormais, merci encore.

    ------------------------------
    LAURENT SANCHEZ
    Developer
    laurent@sanchezconsultant.com
    LE HAVRE
    662527022
    ------------------------------



  • 8.  RE: filtrer avec un SELECTEDVALUE ne fonctionne pas

    Top Contributor
    Posted 17 days ago
    Edited by Guillaume GAUDFROY 17 days ago
    BOnjour

    Avez vous essayé de mettre un relation entre les 2 tables?
    Un simple CountRow devrait suffir.) Même si ici vos projets semble pas être unique.... Est-ce volontaire?

    ------------------------------
    Guillaume GAUDFROY
    Microsoft Data PlatForm MVP
    MCSA Power BI & Excel
    Microsoft MCT
    Ruby Award Dynamic Communities
    ------------------------------